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INSTALLATION

Windows 95/98 & NT 3.5/ 4.0
1. Insert Disk # 1 into 3.5" floppy drive.
2. Click on the START button and then click on the RUN option.
3. Type A:\Setup and click OK. (A: refers to the drive letter of your 3.5" drive.
4. Follow the on screen prompts for disks 2 & 3

OVERVIEW OF SOFTWARE FEATURES

The MATRIX SWITCHER Configuration Software is designed to let the user take full advantage on the
RS-232 options of the MATRIX SWITCHER Presentation Switcher. Some of the Features include:

Model Selection:
The Matrix Switcher Configuration Software can operate two similar models of
the switcher; they are: 1.)  IN31208 and

2.) IN31608

Make the selection from the main menu under Select Model and “right click” the
model of choice.

Com Port Configuration:
This function lets the user easily select the RS-232 Baud Rate settings which the MATRIX
SWITCHER will use in being controlled by a computer or other third party control device.

I/O Configuration
The powerful Direct Mode switching requires that the user define which inputs will be switched to
outputs 1-4.  The I/O Configuration allows the user to define the input to output(s) configuration of
the MATRIX SWITCHER in three user modes: 1) Matrix Mode, 2) Breakaway Audio Mode
and 3) Direct Mode.  Simply click an input and then click the outputs that will activate that output.

The I/O Configuration can then be saved to a database allowing up to 10 configurations to be
saved and loaded.

Program Projector Code
Each button on the MATRIX SWITCHER can be programmed to output codes to control
projectors or other serially controlled audiovisual devices.  Whenever a button is pressed the
corresponding code will be sent out to the projector.  An unlimited number of Projector Control
Code files (PCC) can be saved to the hard disk allowing for multiple configurations to
programmed ahead of time.
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The MATRIX SWITCHER Software allows the user to input the codes into the MATRIX
SWITCHER Switcher.  The projector code configuration can then be written to a file and
retrieved later.

Remote Matrix Switching
Remote Matrix Switching is done through one of three switching panels that are selected as
described below.  These switching panels are: Direct Mode, Matrix Mode and Matrix
Breakaway Audio Mode.

Rename Output and Input Select Buttons
The Output and Input buttons can be renamed to describe the video source.  Clicking the right
mouse button will bring up a text box in which the new name can be entered.  Press Ok and the
name will appear as the new button name.

USING THE MATRIX SWITCHER CONFIGURATION SOFTWARE

The following is the recommended procedure to use the MATRIX SWITCHER Configuration Software to
properly program your MATRIX SWITCHER Presentation Switcher:

Reset to Factory Default:
If the MATRIX SWITCHER is brand new and this is the first time you are using it, you can skip this step
as the unit is set to the Factory default before shipping from the factory.  Resetting the unit to factory default
puts the MATRIX SWITCHER into a known state to ensure the MATRIX SWITCHER Configuration
Software will operate correctly.

To reset the unit to factory defaults:  Turn off the power switch, press and hold the F1 button, turn on
the power switch while continuing to hold the F1 button.  The unit is now set to factory defaults.

Configuring Com Port and Baud Rate:
In controlling the MATRIX SWITCHER from a PC or a third party control device, the RS-232 baud rate
of the two devices must be the same.  Version 3.3.6 automatically polls the MATRIX SWITCHER for the
baud rate at power up.  This software also allows you to set the baud rate of the MATRIX SWITCHER
and additionally sets the baud rate of your PC to that baud rate so that it can communicate with the
MATRIX SWITCHER to configure other parameters:

1.    From the Title Screen select the Configuration Menu.
2. Select the COM Configuration option. This will open the Communication Port

Configuration Window.
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3. Select the COM Port that the MATRIX SWITCHER is attached to on your computer.
COM 1 is usually a Female 9 Pin and COM 2 is usually a Male 25 Pin.

4. Select the Baud Rate, which will be used to control the MATRIX SWITCHER.
5. Select Save Settings at the top of the window.  This will send the appropriate code to the

MATRIX SWITCHER to set it’s baud rate and will set your PC to that baud rate.
6. Select Poll SWITCHER to get the current Baud rate setting.
7. Select Close at the top of the Communication Port Configuration Menu.

Configuring Direct Mode I/O Configuration:
If you are going to use the MATRIX SWITCHER in the Matrix mode, you can skip this section.
In the Direct Mode, every input is pre-assigned to an output or outputs and is automatically sent to the
output(s) when selected.  All other outputs are disconnected (only one input can be active at a time.)  The
software allows you to assign the inputs to outputs as follows:

1. From the MATRIX SWITCHER Configuration Software title screen select the Direct Mode
I/O Configuration under the Configuration Menu.

       This will open the SWITCHER - IO Configuration Window.

2. Click one of the Output buttons.  The “LED” turns blue to identify the selected output.
3. Click the buttons on the Input(s) to be assigned to the selected Output.  The “LEDs” of the

selected input(s) turn blue to indicate they are selected.  In addition, the IO Configuration Map
shows the input(s) assigned to each output.  To de-select an input, click the button again.

4. Repeat steps 2 & 3 for all outputs.  Select Clear to clear all of your IO settings and start over.
5. When done, select Program MATRIX SWITCHER to set the MATRIX SWITCHER into

the Direct Mode and program the I/O Configuration.
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6. Select Exit from the menu to quit the Direct Mode I/O Configuration.

Saving an I/O Configuration to a File:
You can save the IO configuration you have just programmed to a file as follows:

1. Select Save Configuration under the File Menu
2. Enter a name for the configuration file.
3. Click the Save Button

Loading an I/O Configuration File:
You can load a previously saved IO configuration as follows:

1. Select Load Configuration from Disk under the File Menu
2. Type the name of the desired file name or select it from the list.
3. Click the Load Button
4. If you would like to program the MATRIX SWITCHER with the new file now, click

Yes at the prompt.  If not, click No.

Remote Switching

Remote Switching while in Direct Mode:
Enter the Direct Mode Switching menu by:

1. Select Switching from the MATRIX SWITCHER Configuration Program menu.
2. Select the Direct Mode to enter the Direct Mode Switching menu.
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The Remote Switching menu for the Direct Mode for the IN31208 appears, as shown below.

The Remote Switching menu for the Direct Mode for the IN31608 appears, as shown below.

3. Make an output connection path by clicking the desired input.
4. Diagram will take a few seconds to update the while polling the MATRIX

SWITCHER.
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Remote Switching while in Matrix Mode:
Enter the Matrix Mode Switching menu by:

1. Select Switching from the MATRIX SWITCHER Configuration Program menu.
2. Select Matrix Mode: Audio Follow Video to enter the Matrix Switching Mode

menu.

The Remote Switching menu for the Matrix Mode for the IN31208 appears, as shown above.

3. Make an output connection path by clicking the desired input and then clicking the
desired output.  The Mapping Diagram will take a few seconds to update while
polling the MATRIX SWITCHER.

4. The audio associated with the selected input will be automatically routed to the
selected output.
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Remote Switching while in Breakaway Matrix Mode:
Enter the Matrix Mode Switching menu by:

1. Select Switching from the MATRIX SWITCHER Configuration Program menu.
2. Select Matrix Mode: Breakaway Audio to enter the Breakaway Audio Mode

menu.

3. Make an output connection path for video by clicking the desired input and then
clicking the desired output.  The Mapping Diagram will take a few seconds to update
while polling the MATRIX SWITCHER.

4. The audio path is selected as a separate connection path from the video.  To make
Audio connection paths, select the AUDIO CONTROL option from the menu
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5. Make an output connection path for audio by clicking the desired input and then
clicking the desired output.  The Mapping Diagram will take a few seconds to update
while polling the MATRIX SWITCHER.

Muting Outputs and Volume Control
Press the "Mute" button for any output in order to mute the audio for that output.  When an output is
muted, the on-screen LED above the Mute button will turn on (solid green).  Press the Mute button
again to disable the Mute function for that output.

The volume level may be adjusted by pressing the up or down arrow buttons for each output.  The LED
above the Mute button will flash momentarily every time you press one of the arrow buttons, indicating
that a volume change is occurring.
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Breakaway Audio Presets
Saving and loading system configurations is easy to accomplish.  To configure the MATRIX
SWITCHER for the video and audio connection paths desired, select the Setup Menu and click on
Presets.   A menu will appear with three selections, click the appropriate one and follow the easy visual
instructions.

RGB Delay Settings
The RGB Delay settings determine the amount of time that the video sync signal will precede the video
signal.  The Sync signal is connected first and then the video signal is sent after the selected amount of
delay has elapsed.  This is done to avoid any flicker or abrupt jump in the video signal as the
connection path is switched.  From the above menu click on RGB Delay.  The following menu will
appear.

Any selection of delay from 0.0 to 6.0 in 0.100 sec intervals can be chosen by clicking on the
appropriate choice.  The Default setting is 0.0 seconds.
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PROGRAMMING MATRIX SWITCHER WITH PROJECTOR CODES

The external communication port can be used to control a piece of equipment via RS-232, or RS-485.  The
serial format, baud rate, etc. can be set with the software, as well as whether the code to be sent is ASCII or
HEX (Hexadecimal).  When the MATRIX SWITCHER performs certain actions, a code is transmitted out
the communication port.  Codes are sent as follows:

Matrix Mode:
Input and Output Codes:
Each input and output button can store a code.  These codes are sent out whenever a switch is
made.  If just the input is changed (the output does not change) only the input code is sent.
However, if the output and input change, the output code is sent first, followed by the input code.

Function Buttons:
Function Buttons F1, F2, F3 and F4 each hold two codes.  One code is sent when the button is
activated (the LED turns on) and the other is sent when it is deactivated (the LED turns off).

Recall Codes:
When you recall a memory, a code is sent.  Codes can be stored for memories 1 through 9.

Direct Mode:
Input and Output Codes:
Each input and output can store a code.  These codes are sent out whenever a switch is made.  The
input code is always sent, and the output code is sent whenever a different output is activated.

Function Buttons:
Function Buttons F1, F2, F3 and F4 each hold two codes.  One code is sent when the button is
activated (the LED turns on) and the other is sent when it is deactivated.  In addition, since Output
buttons 1 through 4 are not needed for switching functions in the Direct Mode, these buttons now
operate as Function buttons F5, F6, F7 and F8.  Each of these function buttons can also store two
codes.

Procedure:
1. From the Title Screen select the   Projector Control Code Setup option
       under the Configuration Menu.

2. Select Direct Switching Mode or Matrix Switching Mode from the drop down menu to
determine which mode of operation you are using for the MATRIX SWITCHER.  Each
Mode has it’s own drop down menu.
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Direct Mode Projector Port Control Code Configuration Menu
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Matrix Mode Projector Port Control Code Configuration Menu

              4. Click on the button where you would like to store code.

5. The Input Data form will appear
indicating the code to be stored.
Enter the code and click OK.

6. Repeat steps 5 & 6 for all buttons
which will send code.  All buttons
with no code entered will not send
out any code.

7. Select Program MATRIX
SWITCHER under the Program
menu to program the code into the
MATRIX SWITCHER.

8. Select Close Form to exit the
Projector Control Code Setup.
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Saving Projector Codes to a File:
You can save the Projector code you have just entered to a file as follows:

1. Select Save Configuration under the File menu.
2. Enter a name for the file (Must end in .pcc) or select it from the list.
3. Click the OK Button

Loading Projector Codes from a File:
You can load previously saved Projector Codes as follows:

1. Select Load Configuration under the File menu.
2. Enter the name of the desired file or select it from the list.
3. Click the OK Button.

Note: This procedure only loads the information into the software.  You must still program the
MATRIX SWITCHER with the Program menu.

Some ASCII characters cannot be entered
with the keys on your computer keyboard.
Some examples are Line Feed and
Acknowledge (Hexadecimal numbers 0A
and 06.)  To enter these characters when
entering ASCII codes, select Special
ASCII Characters under the View menu
on the Input Data Form as shown in the
screen on the right.  The codes have no
representation other than a line/block.
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SETTING PROJECTOR PORT PARAMETERS

The MATRIX SWITCHER has a serial port designed to communicate with external devices (such as
projectors) via RS-232 or RS-485.  The parity and baud rate are also selectable and can be configured as
follows:

1. From the Title Screen select the Projector Control Code Setup option under the
Configuration Menu.

2. Select Configure MATRIX SWITCHER Projector Port under the Serial Port
Configuration Menu.

3. Select Baud Rate, Parity and Interface type.
4. Click Send to Switcher to send the code to the MATRIX SWITCHER and set the Projector

Port’s parameters.
5.      Click Close Form to exit this setup.
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SERIAL PORT PIN CONFIGURATIONS


